Sergey Kiselev
1 year ago
12 changed files with 84 additions and 73 deletions
@ -1,3 +1,3 @@ |
|||
TIMESTAMP = 1682388062 |
|||
SHA256 (tdesktop-4.8.1-full.tar.gz) = 96660bb151c035a80c5b32a8fe043cecb54e9fe450329cf612ecb752db68c06f |
|||
SIZE (tdesktop-4.8.1-full.tar.gz) = 63997319 |
|||
TIMESTAMP = 1687099818 |
|||
SHA256 (tdesktop-4.8.4-full.tar.gz) = 4328296df07557786e1b9cf22f6675200dbdf29c75d2efeb635c6b7f3f951e8d |
|||
SIZE (tdesktop-4.8.4-full.tar.gz) = 69090626 |
|||
|
@ -1,14 +0,0 @@ |
|||
unbreak clang 13 build |
|||
|
|||
Index: Telegram/SourceFiles/api/api_chat_filters.cpp |
|||
--- Telegram/SourceFiles/api/api_chat_filters.cpp.orig |
|||
+++ Telegram/SourceFiles/api/api_chat_filters.cpp |
|||
@@ -227,7 +227,7 @@ void ImportInvite( |
|||
}; |
|||
auto inputs = peers | ranges::views::transform([](auto peer) { |
|||
return MTPInputPeer(peer->input); |
|||
- }) | ranges::to<QVector>(); |
|||
+ }) | ranges::to<QVector<MTPInputPeer>>(); |
|||
if (!slug.isEmpty()) { |
|||
api->request(MTPchatlists_JoinChatlistInvite( |
|||
MTP_string(slug), |
@ -1,23 +0,0 @@ |
|||
unbreak clang 13 build |
|||
|
|||
Index: Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp |
|||
--- Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp.orig |
|||
+++ Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp |
|||
@@ -1028,7 +1028,7 @@ void ExportFilterLink( |
|||
const auto session = &front->session(); |
|||
auto mtpPeers = peers | ranges::views::transform( |
|||
[](not_null<PeerData*> peer) { return MTPInputPeer(peer->input); } |
|||
- ) | ranges::to<QVector>(); |
|||
+ ) | ranges::to<QVector<MTPInputPeer>>(); |
|||
session->api().request(MTPchatlists_ExportChatlistInvite( |
|||
MTP_inputChatlistDialogFilter(MTP_int(id)), |
|||
MTP_string(), // title |
|||
@@ -1061,7 +1061,7 @@ void EditLinkChats( |
|||
const auto session = &front->session(); |
|||
auto mtpPeers = peers | ranges::views::transform( |
|||
[](not_null<PeerData*> peer) { return MTPInputPeer(peer->input); } |
|||
- ) | ranges::to<QVector>(); |
|||
+ ) | ranges::to<QVector<MTPInputPeer>>(); |
|||
session->api().request(MTPchatlists_EditExportedInvite( |
|||
MTP_flags(MTPchatlists_EditExportedInvite::Flag::f_peers), |
|||
MTP_inputChatlistDialogFilter(MTP_int(link.id)), |
@ -1,14 +0,0 @@ |
|||
unbreak clang 13 build |
|||
|
|||
Index: Telegram/SourceFiles/settings/settings_folders.cpp |
|||
--- Telegram/SourceFiles/settings/settings_folders.cpp.orig |
|||
+++ Telegram/SourceFiles/settings/settings_folders.cpp |
|||
@@ -696,7 +696,7 @@ void FilterRowButton::paintEvent(QPaintEvent *e) { |
|||
row.removePeers |
|||
) | ranges::views::transform([](not_null<PeerData*> peer) { |
|||
return MTPInputPeer(peer->input); |
|||
- }) | ranges::to<QVector>(); |
|||
+ }) | ranges::to<QVector<MTPInputPeer>>(); |
|||
removeChatlistRequests.push_back( |
|||
MTPchatlists_LeaveChatlist( |
|||
MTP_inputChatlistDialogFilter(MTP_int(newId)), |
@ -1,14 +0,0 @@ |
|||
unbreak clang 13 build |
|||
|
|||
Index: Telegram/SourceFiles/window/window_filters_menu.cpp |
|||
--- Telegram/SourceFiles/window/window_filters_menu.cpp.orig |
|||
+++ Telegram/SourceFiles/window/window_filters_menu.cpp |
|||
@@ -494,7 +494,7 @@ void FiltersMenu::remove( |
|||
leave |
|||
) | ranges::views::transform([](not_null<PeerData*> peer) { |
|||
return MTPInputPeer(peer->input); |
|||
- }) | ranges::to<QVector>()) |
|||
+ }) | ranges::to<QVector<MTPInputPeer>>()) |
|||
)).done([=](const MTPUpdates &result) { |
|||
api->applyUpdates(result); |
|||
}).send(); |
@ -0,0 +1,17 @@ |
|||
--- Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp.orig 2023-06-03 03:29:41 UTC |
|||
+++ Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp |
|||
@@ -16,11 +16,12 @@ |
|||
#include <QtGui/QImage> |
|||
#include <ksandbox.h> |
|||
|
|||
-using namespace gi::repository; |
|||
- |
|||
namespace base::Platform { |
|||
|
|||
namespace { |
|||
+ |
|||
+using namespace gi::repository; |
|||
+namespace GObject = gi::repository::GObject; |
|||
|
|||
// QString to GLib::Variant.
|
|||
inline auto Q2V(const QString &s) { |
@ -0,0 +1,13 @@ |
|||
--- cmake/external/glib/cppgir/CMakeLists.txt.orig 2023-05-17 06:10:31 UTC |
|||
+++ cmake/external/glib/cppgir/CMakeLists.txt |
|||
@@ -65,8 +65,8 @@ target_compile_definitions(cppgir PRIVATE |
|||
-DDEFAULT_GIRPATH=${GI_DEFAULT_GIRPATH}) |
|||
target_compile_definitions(cppgir PRIVATE |
|||
-DDEFAULT_IGNORE_FILE=${GI_IGNORE_FILE_INSTALL_DIR}/${GI_IGNORE_FILE}:${GI_IGNORE_FILE_INSTALL_DIR}/${GI_IGNORE_FILE_PLATFORM}) |
|||
-target_link_libraries(cppgir Boost::program_options stdc++fs ${FORMAT_LIBRARIES}) |
|||
-set_property(TARGET cppgir PROPERTY CXX_STANDARD 14) |
|||
+target_link_libraries(cppgir Boost::program_options ${FORMAT_LIBRARIES}) |
|||
+set_property(TARGET cppgir PROPERTY CXX_STANDARD 17) |
|||
|
|||
add_library(gi INTERFACE) |
|||
target_include_directories(gi INTERFACE |
@ -0,0 +1,13 @@ |
|||
--- cmake/external/glib/cppgir/tools/cppgir.cpp.orig 2023-06-15 00:49:41 UTC |
|||
+++ cmake/external/glib/cppgir/tools/cppgir.cpp |
|||
@@ -3,8 +3,8 @@ |
|||
#include "genns.hpp" |
|||
#include "repository.hpp" |
|||
|
|||
-#include <experimental/filesystem> |
|||
-namespace fs = std::experimental::filesystem; |
|||
+#include <filesystem> |
|||
+namespace fs = std::filesystem; |
|||
|
|||
#include <boost/algorithm/string/classification.hpp> |
|||
#include <boost/algorithm/string/split.hpp> |
@ -0,0 +1,8 @@ |
|||
--- cmake/external/glib/cppgir/tools/function.hpp.orig 2023-06-15 00:41:50 UTC |
|||
+++ cmake/external/glib/cppgir/tools/function.hpp |
|||
@@ -1,3 +1,5 @@ |
|||
+#include <map> |
|||
+ |
|||
#ifndef FUNCTION_HPP |
|||
#define FUNCTION_HPP |
|||
|
@ -0,0 +1,8 @@ |
|||
--- cmake/external/glib/cppgir/tools/genbase.cpp.orig 2023-06-15 00:42:39 UTC |
|||
+++ cmake/external/glib/cppgir/tools/genbase.cpp |
|||
@@ -1,3 +1,5 @@ |
|||
+#include <map> |
|||
+ |
|||
#include "genbase.hpp" |
|||
|
|||
static std::string |
@ -0,0 +1,13 @@ |
|||
--- cmake/external/glib/cppgir/tools/genns.cpp.orig 2023-06-15 00:40:47 UTC |
|||
+++ cmake/external/glib/cppgir/tools/genns.cpp |
|||
@@ -5,8 +5,8 @@ |
|||
#include <boost/algorithm/string/join.hpp> |
|||
#include <boost/format.hpp> |
|||
|
|||
-#include <experimental/filesystem> |
|||
-namespace fs = std::experimental::filesystem; |
|||
+#include <filesystem> |
|||
+namespace fs = std::filesystem; |
|||
|
|||
#include <boost/property_tree/xml_parser.hpp> |
|||
|
Loading…
Reference in new issue