Browse Source

Version 4.8.4, revision 4

master
Sergey Kiselev 8 months ago
parent
commit
db78288372
  1. 14
      net-im/telegram-desktop/Makefile
  2. 6
      net-im/telegram-desktop/distinfo
  3. 14
      net-im/telegram-desktop/files/patch-Telegram_SourceFiles_api_api_chat_filters_cpp
  4. 23
      net-im/telegram-desktop/files/patch-Telegram_SourceFiles_boxes_filters_edit_filter_links_cpp
  5. 14
      net-im/telegram-desktop/files/patch-Telegram_SourceFiles_settings_settings_folders_cpp
  6. 14
      net-im/telegram-desktop/files/patch-Telegram_SourceFiles_window_window_filters_menu_cpp
  7. 17
      net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__system__media__controls__linux.cpp
  8. 13
      net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_CMakeLists.txt
  9. 13
      net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_cppgir.cpp
  10. 8
      net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_function.hpp
  11. 8
      net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_genbase.cpp
  12. 13
      net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_genns.cpp

14
net-im/telegram-desktop/Makefile

@ -1,6 +1,6 @@
PORTNAME= telegram-desktop
DISTVERSION= 4.8.1
PORTREVISION= 3
DISTVERSION= 4.8.4
PORTREVISION= 4
CATEGORIES= net-im
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${DISTVERSION}/
DISTNAME= tdesktop-${DISTVERSION}-full
@ -14,10 +14,13 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= does not build, webrtc related
BROKEN_SSL= openssl30 openssl31
BROKEN_SSL_REASON= undefined symbol: ERR_load_BIO_strings
NOT_FOR_ARCHS= powerpc powerpc64 powerpcspe
NOT_FOR_ARCHS_REASON= Only little endian is supported
BUILD_DEPENDS= microsoft-gsl>0:devel/microsoft-gsl \
BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
microsoft-gsl>0:devel/microsoft-gsl \
range-v3>0:devel/range-v3 \
tl-expected>0:devel/tl-expected \
v4l_compat>0:multimedia/v4l_compat \
@ -27,6 +30,7 @@ LIB_DEPENDS= libabsl_base.so:devel/abseil \
libavformat.so:multimedia/ffmpeg \
libdbus-1.so:devel/dbus \
libdispatch.so:devel/libdispatch \
libfmt.so:devel/libfmt \
libhunspell-1.7.so:textproc/hunspell \
liblz4.so:archivers/liblz4 \
libopenh264.so:multimedia/openh264 \
@ -48,7 +52,7 @@ qt5_CONFLICTS_INSTALL= ${PORTNAME}-qt6
qt6_CONFLICTS_INSTALL= ${PORTNAME}
USES= cmake desktop-file-utils gl gnome jpeg localbase \
minizip openal pkgconfig python:3.7+,build ssl xorg
minizip openal pkgconfig python:,build ssl xorg
USE_CXXSTD= c++17
USE_GITHUB= nodefault
@ -66,7 +70,7 @@ USE_QT= 5compat base imageformats lottie shadertools svg tools:build
.endif
USE_GL= gl
USE_GNOME= glib20 glibmm26
USE_GNOME= glib20 glibmm26 introspection
USE_XORG= x11 xcb xcomposite xdamage xext xfixes xrandr xrender xtst
CMAKE_ARGS= -DTDESKTOP_API_ID=${TELEGRAM_API_ID} -DTDESKTOP_API_HASH=${TELEGRAM_API_HASH}

6
net-im/telegram-desktop/distinfo

@ -1,3 +1,3 @@
TIMESTAMP = 1682388062
SHA256 (tdesktop-4.8.1-full.tar.gz) = 96660bb151c035a80c5b32a8fe043cecb54e9fe450329cf612ecb752db68c06f
SIZE (tdesktop-4.8.1-full.tar.gz) = 63997319
TIMESTAMP = 1687099818
SHA256 (tdesktop-4.8.4-full.tar.gz) = 4328296df07557786e1b9cf22f6675200dbdf29c75d2efeb635c6b7f3f951e8d
SIZE (tdesktop-4.8.4-full.tar.gz) = 69090626

14
net-im/telegram-desktop/files/patch-Telegram_SourceFiles_api_api_chat_filters_cpp

@ -1,14 +0,0 @@
unbreak clang 13 build
Index: Telegram/SourceFiles/api/api_chat_filters.cpp
--- Telegram/SourceFiles/api/api_chat_filters.cpp.orig
+++ Telegram/SourceFiles/api/api_chat_filters.cpp
@@ -227,7 +227,7 @@ void ImportInvite(
};
auto inputs = peers | ranges::views::transform([](auto peer) {
return MTPInputPeer(peer->input);
- }) | ranges::to<QVector>();
+ }) | ranges::to<QVector<MTPInputPeer>>();
if (!slug.isEmpty()) {
api->request(MTPchatlists_JoinChatlistInvite(
MTP_string(slug),

23
net-im/telegram-desktop/files/patch-Telegram_SourceFiles_boxes_filters_edit_filter_links_cpp

@ -1,23 +0,0 @@
unbreak clang 13 build
Index: Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp
--- Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp.orig
+++ Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp
@@ -1028,7 +1028,7 @@ void ExportFilterLink(
const auto session = &front->session();
auto mtpPeers = peers | ranges::views::transform(
[](not_null<PeerData*> peer) { return MTPInputPeer(peer->input); }
- ) | ranges::to<QVector>();
+ ) | ranges::to<QVector<MTPInputPeer>>();
session->api().request(MTPchatlists_ExportChatlistInvite(
MTP_inputChatlistDialogFilter(MTP_int(id)),
MTP_string(), // title
@@ -1061,7 +1061,7 @@ void EditLinkChats(
const auto session = &front->session();
auto mtpPeers = peers | ranges::views::transform(
[](not_null<PeerData*> peer) { return MTPInputPeer(peer->input); }
- ) | ranges::to<QVector>();
+ ) | ranges::to<QVector<MTPInputPeer>>();
session->api().request(MTPchatlists_EditExportedInvite(
MTP_flags(MTPchatlists_EditExportedInvite::Flag::f_peers),
MTP_inputChatlistDialogFilter(MTP_int(link.id)),

14
net-im/telegram-desktop/files/patch-Telegram_SourceFiles_settings_settings_folders_cpp

@ -1,14 +0,0 @@
unbreak clang 13 build
Index: Telegram/SourceFiles/settings/settings_folders.cpp
--- Telegram/SourceFiles/settings/settings_folders.cpp.orig
+++ Telegram/SourceFiles/settings/settings_folders.cpp
@@ -696,7 +696,7 @@ void FilterRowButton::paintEvent(QPaintEvent *e) {
row.removePeers
) | ranges::views::transform([](not_null<PeerData*> peer) {
return MTPInputPeer(peer->input);
- }) | ranges::to<QVector>();
+ }) | ranges::to<QVector<MTPInputPeer>>();
removeChatlistRequests.push_back(
MTPchatlists_LeaveChatlist(
MTP_inputChatlistDialogFilter(MTP_int(newId)),

14
net-im/telegram-desktop/files/patch-Telegram_SourceFiles_window_window_filters_menu_cpp

@ -1,14 +0,0 @@
unbreak clang 13 build
Index: Telegram/SourceFiles/window/window_filters_menu.cpp
--- Telegram/SourceFiles/window/window_filters_menu.cpp.orig
+++ Telegram/SourceFiles/window/window_filters_menu.cpp
@@ -494,7 +494,7 @@ void FiltersMenu::remove(
leave
) | ranges::views::transform([](not_null<PeerData*> peer) {
return MTPInputPeer(peer->input);
- }) | ranges::to<QVector>())
+ }) | ranges::to<QVector<MTPInputPeer>>())
)).done([=](const MTPUpdates &result) {
api->applyUpdates(result);
}).send();

17
net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__system__media__controls__linux.cpp

@ -0,0 +1,17 @@
--- Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp.orig 2023-06-03 03:29:41 UTC
+++ Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp
@@ -16,11 +16,12 @@
#include <QtGui/QImage>
#include <ksandbox.h>
-using namespace gi::repository;
-
namespace base::Platform {
namespace {
+
+using namespace gi::repository;
+namespace GObject = gi::repository::GObject;
// QString to GLib::Variant.
inline auto Q2V(const QString &s) {

13
net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_CMakeLists.txt

@ -0,0 +1,13 @@
--- cmake/external/glib/cppgir/CMakeLists.txt.orig 2023-05-17 06:10:31 UTC
+++ cmake/external/glib/cppgir/CMakeLists.txt
@@ -65,8 +65,8 @@ target_compile_definitions(cppgir PRIVATE
-DDEFAULT_GIRPATH=${GI_DEFAULT_GIRPATH})
target_compile_definitions(cppgir PRIVATE
-DDEFAULT_IGNORE_FILE=${GI_IGNORE_FILE_INSTALL_DIR}/${GI_IGNORE_FILE}:${GI_IGNORE_FILE_INSTALL_DIR}/${GI_IGNORE_FILE_PLATFORM})
-target_link_libraries(cppgir Boost::program_options stdc++fs ${FORMAT_LIBRARIES})
-set_property(TARGET cppgir PROPERTY CXX_STANDARD 14)
+target_link_libraries(cppgir Boost::program_options ${FORMAT_LIBRARIES})
+set_property(TARGET cppgir PROPERTY CXX_STANDARD 17)
add_library(gi INTERFACE)
target_include_directories(gi INTERFACE

13
net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_cppgir.cpp

@ -0,0 +1,13 @@
--- cmake/external/glib/cppgir/tools/cppgir.cpp.orig 2023-06-15 00:49:41 UTC
+++ cmake/external/glib/cppgir/tools/cppgir.cpp
@@ -3,8 +3,8 @@
#include "genns.hpp"
#include "repository.hpp"
-#include <experimental/filesystem>
-namespace fs = std::experimental::filesystem;
+#include <filesystem>
+namespace fs = std::filesystem;
#include <boost/algorithm/string/classification.hpp>
#include <boost/algorithm/string/split.hpp>

8
net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_function.hpp

@ -0,0 +1,8 @@
--- cmake/external/glib/cppgir/tools/function.hpp.orig 2023-06-15 00:41:50 UTC
+++ cmake/external/glib/cppgir/tools/function.hpp
@@ -1,3 +1,5 @@
+#include <map>
+
#ifndef FUNCTION_HPP
#define FUNCTION_HPP

8
net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_genbase.cpp

@ -0,0 +1,8 @@
--- cmake/external/glib/cppgir/tools/genbase.cpp.orig 2023-06-15 00:42:39 UTC
+++ cmake/external/glib/cppgir/tools/genbase.cpp
@@ -1,3 +1,5 @@
+#include <map>
+
#include "genbase.hpp"
static std::string

13
net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_genns.cpp

@ -0,0 +1,13 @@
--- cmake/external/glib/cppgir/tools/genns.cpp.orig 2023-06-15 00:40:47 UTC
+++ cmake/external/glib/cppgir/tools/genns.cpp
@@ -5,8 +5,8 @@
#include <boost/algorithm/string/join.hpp>
#include <boost/format.hpp>
-#include <experimental/filesystem>
-namespace fs = std::experimental::filesystem;
+#include <filesystem>
+namespace fs = std::filesystem;
#include <boost/property_tree/xml_parser.hpp>
Loading…
Cancel
Save