Sergey Kiselev
1 year ago
4 changed files with 68 additions and 1 deletions
@ -0,0 +1,11 @@ |
|||
--- Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp.orig 2023-10-02 20:31:34 UTC |
|||
+++ Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp |
|||
@@ -814,7 +814,7 @@ bool ByDefault() { |
|||
|
|||
// A list of capabilities that offer feature parity
|
|||
// with custom notifications
|
|||
- return ranges::all_of(std::initializer_list{ |
|||
+ return ranges::all_of(std::array{ |
|||
// To show message content
|
|||
"body", |
|||
// To have buttons on notifications
|
@ -0,0 +1,44 @@ |
|||
--- cmake/external/qt/CMakeLists.txt.orig 2023-09-13 17:06:28 UTC |
|||
+++ cmake/external/qt/CMakeLists.txt |
|||
@@ -16,6 +16,8 @@ if (DESKTOP_APP_USE_PACKAGED) |
|||
Qt::CorePrivate |
|||
Qt::Gui |
|||
Qt::GuiPrivate |
|||
+ $<TARGET_NAME_IF_EXISTS:Qt::ServiceSupport> |
|||
+ $<TARGET_NAME_IF_EXISTS:Qt::ServiceSupportPrivate> |
|||
$<TARGET_NAME_IF_EXISTS:Qt::OpenGL> |
|||
Qt::Widgets |
|||
Qt::WidgetsPrivate |
|||
@@ -36,6 +38,7 @@ INTERFACE |
|||
${qt_loc}/include |
|||
${qt_loc}/include/QtCore |
|||
${qt_loc}/include/QtGui |
|||
+ $<$<TARGET_EXISTS:Qt::ServiceSupport>:${qt_loc}/include/QtServiceSupport> |
|||
$<$<TARGET_EXISTS:Qt::OpenGL>:${qt_loc}/include/QtOpenGL> |
|||
${qt_loc}/include/QtWidgets |
|||
$<$<TARGET_EXISTS:Qt::OpenGLWidgets>:${qt_loc}/include/QtOpenGLWidgets> |
|||
@@ -46,9 +49,11 @@ INTERFACE |
|||
$<$<TARGET_EXISTS:Qt::WaylandCompositor>:${qt_loc}/include/QtWaylandCompositor> |
|||
${qt_loc}/include/QtCore/${qt_version} |
|||
${qt_loc}/include/QtGui/${qt_version} |
|||
+ ${qt_loc}/include/QtServiceSupport/${qt_version} |
|||
${qt_loc}/include/QtWidgets/${qt_version} |
|||
${qt_loc}/include/QtCore/${qt_version}/QtCore |
|||
${qt_loc}/include/QtGui/${qt_version}/QtGui |
|||
+ ${qt_loc}/include/QtServiceSupport/${qt_version}/QtServiceSupport |
|||
${qt_loc}/include/QtWidgets/${qt_version}/QtWidgets |
|||
) |
|||
|
|||
@@ -92,6 +97,12 @@ set(common_qt_libs |
|||
lib/${qt_lib_prefix}Qt${QT_VERSION_MAJOR}Gui |
|||
lib/${qt_lib_prefix}Qt${QT_VERSION_MAJOR}Core |
|||
) |
|||
+ |
|||
+if (TARGET Qt::ServiceSupport) |
|||
+ list(PREPEND common_qt_libs |
|||
+ lib/${qt_lib_prefix}Qt${QT_VERSION_MAJOR}ServiceSupport |
|||
+ ) |
|||
+endif() |
|||
|
|||
if (TARGET Qt::OpenGL) |
|||
list(PREPEND common_qt_libs |
@ -0,0 +1,11 @@ |
|||
--- cmake/external/qt/package.cmake.orig 2023-09-13 17:06:28 UTC |
|||
+++ cmake/external/qt/package.cmake |
|||
@@ -45,6 +45,8 @@ if (QT_VERSION_MAJOR GREATER_EQUAL 6) |
|||
set(qt_version_6_5_or_greater 1) |
|||
endif() |
|||
find_package(Qt${QT_VERSION_MAJOR} COMPONENTS OpenGL OpenGLWidgets REQUIRED) |
|||
+else() |
|||
+ find_package(Qt${QT_VERSION_MAJOR} COMPONENTS ServiceSupport REQUIRED) |
|||
endif() |
|||
|
|||
# QtWaylandScanner cmake integration from Qt 6 is used |
Loading…
Reference in new issue