Browse Source

Version 4.10.3, port revision 1

master
Sergey Kiselev 6 months ago
parent
commit
9a2c815d46
  1. 3
      net-im/telegram-desktop/Makefile
  2. 11
      net-im/telegram-desktop/files/patch-Telegram_SourceFiles_platform_linux_notifications__manager__linux.cpp
  3. 44
      net-im/telegram-desktop/files/patch-cmake_external_qt_CMakeLists.txt
  4. 11
      net-im/telegram-desktop/files/patch-cmake_external_qt_package.cmake

3
net-im/telegram-desktop/Makefile

@ -1,5 +1,6 @@
PORTNAME= telegram-desktop
DISTVERSION= 4.10.3
PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${DISTVERSION}/
DISTNAME= tdesktop-${DISTVERSION}-full
@ -13,7 +14,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= does not build, webrtc related
BROKEN_SSL= openssl30 openssl31
BROKEN_SSL= openssl openssl31
BROKEN_SSL_REASON= undefined symbol: ERR_load_BIO_strings
NOT_FOR_ARCHS= powerpc powerpc64 powerpcspe
NOT_FOR_ARCHS_REASON= Only little endian is supported

11
net-im/telegram-desktop/files/patch-Telegram_SourceFiles_platform_linux_notifications__manager__linux.cpp

@ -0,0 +1,11 @@
--- Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp.orig 2023-10-02 20:31:34 UTC
+++ Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp
@@ -814,7 +814,7 @@ bool ByDefault() {
// A list of capabilities that offer feature parity
// with custom notifications
- return ranges::all_of(std::initializer_list{
+ return ranges::all_of(std::array{
// To show message content
"body",
// To have buttons on notifications

44
net-im/telegram-desktop/files/patch-cmake_external_qt_CMakeLists.txt

@ -0,0 +1,44 @@
--- cmake/external/qt/CMakeLists.txt.orig 2023-09-13 17:06:28 UTC
+++ cmake/external/qt/CMakeLists.txt
@@ -16,6 +16,8 @@ if (DESKTOP_APP_USE_PACKAGED)
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
+ $<TARGET_NAME_IF_EXISTS:Qt::ServiceSupport>
+ $<TARGET_NAME_IF_EXISTS:Qt::ServiceSupportPrivate>
$<TARGET_NAME_IF_EXISTS:Qt::OpenGL>
Qt::Widgets
Qt::WidgetsPrivate
@@ -36,6 +38,7 @@ INTERFACE
${qt_loc}/include
${qt_loc}/include/QtCore
${qt_loc}/include/QtGui
+ $<$<TARGET_EXISTS:Qt::ServiceSupport>:${qt_loc}/include/QtServiceSupport>
$<$<TARGET_EXISTS:Qt::OpenGL>:${qt_loc}/include/QtOpenGL>
${qt_loc}/include/QtWidgets
$<$<TARGET_EXISTS:Qt::OpenGLWidgets>:${qt_loc}/include/QtOpenGLWidgets>
@@ -46,9 +49,11 @@ INTERFACE
$<$<TARGET_EXISTS:Qt::WaylandCompositor>:${qt_loc}/include/QtWaylandCompositor>
${qt_loc}/include/QtCore/${qt_version}
${qt_loc}/include/QtGui/${qt_version}
+ ${qt_loc}/include/QtServiceSupport/${qt_version}
${qt_loc}/include/QtWidgets/${qt_version}
${qt_loc}/include/QtCore/${qt_version}/QtCore
${qt_loc}/include/QtGui/${qt_version}/QtGui
+ ${qt_loc}/include/QtServiceSupport/${qt_version}/QtServiceSupport
${qt_loc}/include/QtWidgets/${qt_version}/QtWidgets
)
@@ -92,6 +97,12 @@ set(common_qt_libs
lib/${qt_lib_prefix}Qt${QT_VERSION_MAJOR}Gui
lib/${qt_lib_prefix}Qt${QT_VERSION_MAJOR}Core
)
+
+if (TARGET Qt::ServiceSupport)
+ list(PREPEND common_qt_libs
+ lib/${qt_lib_prefix}Qt${QT_VERSION_MAJOR}ServiceSupport
+ )
+endif()
if (TARGET Qt::OpenGL)
list(PREPEND common_qt_libs

11
net-im/telegram-desktop/files/patch-cmake_external_qt_package.cmake

@ -0,0 +1,11 @@
--- cmake/external/qt/package.cmake.orig 2023-09-13 17:06:28 UTC
+++ cmake/external/qt/package.cmake
@@ -45,6 +45,8 @@ if (QT_VERSION_MAJOR GREATER_EQUAL 6)
set(qt_version_6_5_or_greater 1)
endif()
find_package(Qt${QT_VERSION_MAJOR} COMPONENTS OpenGL OpenGLWidgets REQUIRED)
+else()
+ find_package(Qt${QT_VERSION_MAJOR} COMPONENTS ServiceSupport REQUIRED)
endif()
# QtWaylandScanner cmake integration from Qt 6 is used
Loading…
Cancel
Save