Browse Source

Version 4.8.1, port revision 2

master
Sergey Kiselev 1 year ago
parent
commit
cd0afa49d9
  1. 7
      net-im/telegram-desktop/Makefile
  2. 2
      net-im/telegram-desktop/distinfo
  3. 14
      net-im/telegram-desktop/files/patch-Telegram_SourceFiles_api_api_chat_filters_cpp
  4. 23
      net-im/telegram-desktop/files/patch-Telegram_SourceFiles_boxes_filters_edit_filter_links_cpp
  5. 14
      net-im/telegram-desktop/files/patch-Telegram_SourceFiles_settings_settings_folders_cpp
  6. 14
      net-im/telegram-desktop/files/patch-Telegram_SourceFiles_window_window_filters_menu_cpp

7
net-im/telegram-desktop/Makefile

@ -1,5 +1,6 @@
PORTNAME= telegram-desktop
DISTVERSION= 4.8.1
PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${DISTVERSION}/
DISTNAME= tdesktop-${DISTVERSION}-full
@ -86,15 +87,15 @@ OPTIONS_GROUP= AUDIO
OPTIONS_GROUP_AUDIO= ALSA PULSEAUDIO
AUDIO_DESC= Audio backend for voice calls
SYSTEM_FONTS_DESC= Use system fonts instead of bundled patches ones
SYSTEM_FONTS_DESC= Use system fonts instead of bundled patched ones
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
ALSA_CMAKE_BOOL_OFF= LIBTGVOIP_DISABLE_ALSA
PULSEAUDIO_CMAKE_BOOL_OFF= LIBTGVOIP_DISABLE_PULSEAUDIO
SYSTEM_FONTS_CMAKE_BOOL_OFF= DESKTOP_APP_USE_PACKAGED_FONTS
WAYLAND_CMAKE_BOOL_OFF= DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION
WAYLAND_USE= qt=wayland
WAYLAND_CMAKE_BOOL_OFF= DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION
WAYLAND_USE= qt=wayland
# Telegram asks each custom build to have its own API ID and hash.
TELEGRAM_API_HASH= 20a3432aab43f24bb4460fceac5ba38d

2
net-im/telegram-desktop/distinfo

@ -1,3 +1,3 @@
TIMESTAMP = 1682392557
TIMESTAMP = 1682388062
SHA256 (tdesktop-4.8.1-full.tar.gz) = 96660bb151c035a80c5b32a8fe043cecb54e9fe450329cf612ecb752db68c06f
SIZE (tdesktop-4.8.1-full.tar.gz) = 63997319

14
net-im/telegram-desktop/files/patch-Telegram_SourceFiles_api_api_chat_filters_cpp

@ -0,0 +1,14 @@
unbreak clang 13 build
Index: Telegram/SourceFiles/api/api_chat_filters.cpp
--- Telegram/SourceFiles/api/api_chat_filters.cpp.orig
+++ Telegram/SourceFiles/api/api_chat_filters.cpp
@@ -227,7 +227,7 @@ void ImportInvite(
};
auto inputs = peers | ranges::views::transform([](auto peer) {
return MTPInputPeer(peer->input);
- }) | ranges::to<QVector>();
+ }) | ranges::to<QVector<MTPInputPeer>>();
if (!slug.isEmpty()) {
api->request(MTPchatlists_JoinChatlistInvite(
MTP_string(slug),

23
net-im/telegram-desktop/files/patch-Telegram_SourceFiles_boxes_filters_edit_filter_links_cpp

@ -0,0 +1,23 @@
unbreak clang 13 build
Index: Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp
--- Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp.orig
+++ Telegram/SourceFiles/boxes/filters/edit_filter_links.cpp
@@ -1028,7 +1028,7 @@ void ExportFilterLink(
const auto session = &front->session();
auto mtpPeers = peers | ranges::views::transform(
[](not_null<PeerData*> peer) { return MTPInputPeer(peer->input); }
- ) | ranges::to<QVector>();
+ ) | ranges::to<QVector<MTPInputPeer>>();
session->api().request(MTPchatlists_ExportChatlistInvite(
MTP_inputChatlistDialogFilter(MTP_int(id)),
MTP_string(), // title
@@ -1061,7 +1061,7 @@ void EditLinkChats(
const auto session = &front->session();
auto mtpPeers = peers | ranges::views::transform(
[](not_null<PeerData*> peer) { return MTPInputPeer(peer->input); }
- ) | ranges::to<QVector>();
+ ) | ranges::to<QVector<MTPInputPeer>>();
session->api().request(MTPchatlists_EditExportedInvite(
MTP_flags(MTPchatlists_EditExportedInvite::Flag::f_peers),
MTP_inputChatlistDialogFilter(MTP_int(link.id)),

14
net-im/telegram-desktop/files/patch-Telegram_SourceFiles_settings_settings_folders_cpp

@ -0,0 +1,14 @@
unbreak clang 13 build
Index: Telegram/SourceFiles/settings/settings_folders.cpp
--- Telegram/SourceFiles/settings/settings_folders.cpp.orig
+++ Telegram/SourceFiles/settings/settings_folders.cpp
@@ -696,7 +696,7 @@ void FilterRowButton::paintEvent(QPaintEvent *e) {
row.removePeers
) | ranges::views::transform([](not_null<PeerData*> peer) {
return MTPInputPeer(peer->input);
- }) | ranges::to<QVector>();
+ }) | ranges::to<QVector<MTPInputPeer>>();
removeChatlistRequests.push_back(
MTPchatlists_LeaveChatlist(
MTP_inputChatlistDialogFilter(MTP_int(newId)),

14
net-im/telegram-desktop/files/patch-Telegram_SourceFiles_window_window_filters_menu_cpp

@ -0,0 +1,14 @@
unbreak clang 13 build
Index: Telegram/SourceFiles/window/window_filters_menu.cpp
--- Telegram/SourceFiles/window/window_filters_menu.cpp.orig
+++ Telegram/SourceFiles/window/window_filters_menu.cpp
@@ -494,7 +494,7 @@ void FiltersMenu::remove(
leave
) | ranges::views::transform([](not_null<PeerData*> peer) {
return MTPInputPeer(peer->input);
- }) | ranges::to<QVector>())
+ }) | ranges::to<QVector<MTPInputPeer>>())
)).done([=](const MTPUpdates &result) {
api->applyUpdates(result);
}).send();
Loading…
Cancel
Save