Browse Source

Remove patch files

master
Sergey Kiselev 7 months ago
parent
commit
264e15feee
  1. 17
      net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__system__media__controls__linux.cpp
  2. 13
      net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_CMakeLists.txt
  3. 13
      net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_cppgir.cpp
  4. 8
      net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_function.hpp
  5. 8
      net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_genbase.cpp
  6. 13
      net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_genns.cpp

17
net-im/telegram-desktop/files/patch-Telegram_lib__base_base_platform_linux_base__system__media__controls__linux.cpp

@ -1,17 +0,0 @@
--- Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp.orig 2023-06-03 03:29:41 UTC
+++ Telegram/lib_base/base/platform/linux/base_system_media_controls_linux.cpp
@@ -16,11 +16,12 @@
#include <QtGui/QImage>
#include <ksandbox.h>
-using namespace gi::repository;
-
namespace base::Platform {
namespace {
+
+using namespace gi::repository;
+namespace GObject = gi::repository::GObject;
// QString to GLib::Variant.
inline auto Q2V(const QString &s) {

13
net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_CMakeLists.txt

@ -1,13 +0,0 @@
--- cmake/external/glib/cppgir/CMakeLists.txt.orig 2023-05-17 06:10:31 UTC
+++ cmake/external/glib/cppgir/CMakeLists.txt
@@ -65,8 +65,8 @@ target_compile_definitions(cppgir PRIVATE
-DDEFAULT_GIRPATH=${GI_DEFAULT_GIRPATH})
target_compile_definitions(cppgir PRIVATE
-DDEFAULT_IGNORE_FILE=${GI_IGNORE_FILE_INSTALL_DIR}/${GI_IGNORE_FILE}:${GI_IGNORE_FILE_INSTALL_DIR}/${GI_IGNORE_FILE_PLATFORM})
-target_link_libraries(cppgir Boost::program_options stdc++fs ${FORMAT_LIBRARIES})
-set_property(TARGET cppgir PROPERTY CXX_STANDARD 14)
+target_link_libraries(cppgir Boost::program_options ${FORMAT_LIBRARIES})
+set_property(TARGET cppgir PROPERTY CXX_STANDARD 17)
add_library(gi INTERFACE)
target_include_directories(gi INTERFACE

13
net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_cppgir.cpp

@ -1,13 +0,0 @@
--- cmake/external/glib/cppgir/tools/cppgir.cpp.orig 2023-06-15 00:49:41 UTC
+++ cmake/external/glib/cppgir/tools/cppgir.cpp
@@ -3,8 +3,8 @@
#include "genns.hpp"
#include "repository.hpp"
-#include <experimental/filesystem>
-namespace fs = std::experimental::filesystem;
+#include <filesystem>
+namespace fs = std::filesystem;
#include <boost/algorithm/string/classification.hpp>
#include <boost/algorithm/string/split.hpp>

8
net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_function.hpp

@ -1,8 +0,0 @@
--- cmake/external/glib/cppgir/tools/function.hpp.orig 2023-06-15 00:41:50 UTC
+++ cmake/external/glib/cppgir/tools/function.hpp
@@ -1,3 +1,5 @@
+#include <map>
+
#ifndef FUNCTION_HPP
#define FUNCTION_HPP

8
net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_genbase.cpp

@ -1,8 +0,0 @@
--- cmake/external/glib/cppgir/tools/genbase.cpp.orig 2023-06-15 00:42:39 UTC
+++ cmake/external/glib/cppgir/tools/genbase.cpp
@@ -1,3 +1,5 @@
+#include <map>
+
#include "genbase.hpp"
static std::string

13
net-im/telegram-desktop/files/patch-cmake_external_glib_cppgir_tools_genns.cpp

@ -1,13 +0,0 @@
--- cmake/external/glib/cppgir/tools/genns.cpp.orig 2023-06-15 00:40:47 UTC
+++ cmake/external/glib/cppgir/tools/genns.cpp
@@ -5,8 +5,8 @@
#include <boost/algorithm/string/join.hpp>
#include <boost/format.hpp>
-#include <experimental/filesystem>
-namespace fs = std::experimental::filesystem;
+#include <filesystem>
+namespace fs = std::filesystem;
#include <boost/property_tree/xml_parser.hpp>
Loading…
Cancel
Save